Quantcast

genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

M G Berberich-6

Hello,

on a Canon LiDE 210, the 600 dpi Gray and Lineart scans are distorted
by a factor of 1.5 in y-direction (the scanner seems to scans with
600×900 dpi).

Example:
The image at http://m-berberich.de/Diverses/genesys-600dpi-Gray.png
shows a 600 dpi Gray scan from a 5×5mm grid-paper, done with

  scanimage -l 20mm -t 20mm -x 45mm -y 45mm --resolution 600 --mode Gray

        MfG
        bmg

--
„Des is völlig wurscht, was heut beschlos- | M G Berberich
 sen wird: I bin sowieso dagegn!“          | [hidden email]
(SPD-Stadtrat Kurt Schindler; Regensburg)  | www.fmi.uni-passau.de/~berberic

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

stef-22
On 15/09/2015 15:57, M G Berberich wrote:

> Hello,
>
> on a Canon LiDE 210, the 600 dpi Gray and Lineart scans are distorted
> by a factor of 1.5 in y-direction (the scanner seems to scans with
> 600×900 dpi).
>
> Example:
> The image at http://m-berberich.de/Diverses/genesys-600dpi-Gray.png
> shows a 600 dpi Gray scan from a 5×5mm grid-paper, done with
>
>    scanimage -l 20mm -t 20mm -x 45mm -y 45mm --resolution 600 --mode Gray
>
> MfG
> bmg
>
     Hello,

     it is a known bug, see
https://alioth.debian.org/tracker/index.php?group_id=30186&atid=410366 .

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

M G Berberich-6
Hello,

Am Mittwoch, den 16. September schrieb Stef:

> On 15/09/2015 15:57, M G Berberich wrote:
> >on a Canon LiDE 210, the 600 dpi Gray and Lineart scans are distorted
> >by a factor of 1.5 in y-direction (the scanner seems to scans with
> >600×900 dpi).
> >
> >Example:
> >The image at http://m-berberich.de/Diverses/genesys-600dpi-Gray.png
> >shows a 600 dpi Gray scan from a 5×5mm grid-paper, done with
> >
> >   scanimage -l 20mm -t 20mm -x 45mm -y 45mm --resolution 600 --mode Gray
>
>     it is a known bug, see
> https://alioth.debian.org/tracker/index.php?group_id=30186&atid=410366 .

The bug must have been introduced between 2013-07-02 (bd0f989) and
2013-07-17 (1c3ec28) probably in commit

   define specific LIDE210 sensor and motor instead of using LIDE110
   ones

from 2013-07-04 (730a2ba and 599f3ed).

Anybody able to (re)fix this?

        MfG
        bmg

--
„Des is völlig wurscht, was heut beschlos- | M G Berberich
 sen wird: I bin sowieso dagegn!“          | [hidden email]
(SPD-Stadtrat Kurt Schindler; Regensburg)  | www.fmi.uni-passau.de/~berberic

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

stef-22
On 21/09/2015 21:04, M G Berberich wrote:

> Hello,
>
> Am Mittwoch, den 16. September schrieb Stef:
>> On 15/09/2015 15:57, M G Berberich wrote:
>>> on a Canon LiDE 210, the 600 dpi Gray and Lineart scans are distorted
>>> by a factor of 1.5 in y-direction (the scanner seems to scans with
>>> 600×900 dpi).
>>>
>>> Example:
>>> The image at http://m-berberich.de/Diverses/genesys-600dpi-Gray.png
>>> shows a 600 dpi Gray scan from a 5×5mm grid-paper, done with
>>>
>>>    scanimage -l 20mm -t 20mm -x 45mm -y 45mm --resolution 600 --mode Gray
>>      it is a known bug, see
>> https://alioth.debian.org/tracker/index.php?group_id=30186&atid=410366 .
> The bug must have been introduced between 2013-07-02 (bd0f989) and
> 2013-07-17 (1c3ec28) probably in commit
>
>     define specific LIDE210 sensor and motor instead of using LIDE110
>     ones
>
> from 2013-07-04 (730a2ba and 599f3ed).
>
> Anybody able to (re)fix this?
>
> MfG
> bmg
>
     Hello,

     previous code did gave the right number of lines. But those were of
a higher resolution, giving improper aspect ratio. It cannot be fixed by
reverted some changes.

     There are 3 options:
     - don't pretend the backend can do scan at these low resolution,
and set 600 dpi as the lowest resolution in color, and 900 in gray, and
let the user crop the picture.
     - do a 900x600 dpi scan (don't set yres = xres), which frontends
rarely (if any) handle correctly
     - introduce yet another transformation stage in scan and do
cropping into the backend.

     I personally consider the latter. However the "data pipeline" from
raw data to sane compliant data has grown to the point it deserves some
rewrite. This will take time.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

M G Berberich-6
Am Samstag, den 26. September schrieb Stef:

> On 21/09/2015 21:04, M G Berberich wrote:
> >Hello,
> >
> >Am Mittwoch, den 16. September schrieb Stef:
> >>On 15/09/2015 15:57, M G Berberich wrote:
> >>>on a Canon LiDE 210, the 600 dpi Gray and Lineart scans are distorted
> >>>by a factor of 1.5 in y-direction (the scanner seems to scans with
> >>>600×900 dpi).
> >>>
> >>>Example:
> >>>The image at http://m-berberich.de/Diverses/genesys-600dpi-Gray.png
> >>>shows a 600 dpi Gray scan from a 5×5mm grid-paper, done with
> >>>
> >>>   scanimage -l 20mm -t 20mm -x 45mm -y 45mm --resolution 600 --mode Gray
> >>     it is a known bug, see
> >>https://alioth.debian.org/tracker/index.php?group_id=30186&atid=410366 .
> >The bug must have been introduced between 2013-07-02 (bd0f989) and
> >2013-07-17 (1c3ec28) probably in commit
> >
> >    define specific LIDE210 sensor and motor instead of using LIDE110
> >    ones
> >
> >from 2013-07-04 (730a2ba and 599f3ed).
> >
> >Anybody able to (re)fix this?
> >
> > MfG
> > bmg
> >
>     Hello,
>
>     previous code did gave the right number of lines. But those were of a
> higher resolution, giving improper aspect ratio. It cannot be fixed by
> reverted some changes.
>
>     There are 3 options:
>     - don't pretend the backend can do scan at these low resolution, and set
> 600 dpi as the lowest resolution in color, and 900 in gray, and let the user
> crop the picture.
>     - do a 900x600 dpi scan (don't set yres = xres), which frontends rarely
> (if any) handle correctly
>     - introduce yet another transformation stage in scan and do cropping
> into the backend.
>
>     I personally consider the latter. However the "data pipeline" from raw
> data to sane compliant data has grown to the point it deserves some rewrite.
> This will take time.

I’m a bit puzzled. The old code (bd0f989 and befor) did
600dpi-gray/lineart-scans with correct aspect-ration. How did it do
it?

        MfG
        bmg

--
„Des is völlig wurscht, was heut beschlos- | M G Berberich
 sen wird: I bin sowieso dagegn!“          | [hidden email]
(SPD-Stadtrat Kurt Schindler; Regensburg)  | www.fmi.uni-passau.de/~berberic

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

stef-22
On 07/10/2015 22:51, M G Berberich wrote:
> I’m a bit puzzled. The old code (bd0f989 and befor) did
> 600dpi-gray/lineart-scans with correct aspect-ration. How did it do
> it? MfG bmg
     Hello,

     old code was scanning at higher vertical resolution and getting
more lines, then dropped lines to match the desired resolution. There
was no line averaging.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

Yury Tarasievich-3
I might be talking completely off-point, but
scanning at 600dpi b/w takes 2+ minutes on canon
lide 25 (IIRC this is an older genesys chip).

Yury

On 10/08/2015 07:06 AM, Stef wrote:

> On 07/10/2015 22:51, M G Berberich wrote:
>> I’m a bit puzzled. The old code (bd0f989 and
>> befor) did 600dpi-gray/lineart-scans with
>> correct aspect-ration. How did it do it? MfG bmg
>      Hello,
>
>      old code was scanning at higher vertical
> resolution and getting more lines, then dropped
> lines to match the desired resolution. There was
> no line averaging.

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: genesys 600 dpi Gray and Lineart distorted by factor 1.5 in y-direction

stef-22
On 11/10/2015 19:43, Yury Tarasievich wrote:
> I might be talking completely off-point, but scanning at 600dpi b/w
> takes 2+ minutes on canon lide 25 (IIRC this is an older genesys chip).
>
> Yury
>
     Hello,

     this is not the case for LiDE 100/200/110/210. They are faster, and
the windows driver always scan at least at 300 dpi color, which resolves
to 900 dpi motor speed or 600 dpi for grayscale.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Loading...