LiDE 120, small changes pushed in git

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

LiDE 120, small changes pushed in git

stef-22
     Hello,

     I have pushed some small changes that should improve support for
the LiDE 120 for resolutions up to 600 dpi. Please test this build 2507
of the geneys backend (check this version number in debug logs when
testing).
     Working with some logs sent, then throwing back some code to
someone else to test isn't practical. I don't feel like going on that
way. So people interested by adding support for this model (or another
one) should clone SANE's git tree and syseneg project (which provides a
tool to analyze pcap usb logs), and start hacking it.
     I'd be happy to improve genesys backend's doc to help, and will
gladly apply patches.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LiDE 120, small changes pushed in git

martin.gallezot
Hello,

I have tested the latest build available from git. Unfortunately I wasn't able to check the version number. which debug logs are you referring to ?

Anyway with the latest build, my LiDe 120 is not supported at all (even with resolution under 600 dpi).

It may well be that I made a mistake at compile or forgot to update a configuration file. Anyone else had a chance to try it ?

Thanks,

Martin

----- Mail original -----
De: "Stef" <[hidden email]>
À: "Sane Development" <[hidden email]>
Envoyé: Jeudi 11 Juin 2015 21:55:07
Objet: [sane-devel] LiDE 120, small changes pushed in git

     Hello,

     I have pushed some small changes that should improve support for
the LiDE 120 for resolutions up to 600 dpi. Please test this build 2507
of the geneys backend (check this version number in debug logs when
testing).
     Working with some logs sent, then throwing back some code to
someone else to test isn't practical. I don't feel like going on that
way. So people interested by adding support for this model (or another
one) should clone SANE's git tree and syseneg project (which provides a
tool to analyze pcap usb logs), and start hacking it.
     I'd be happy to improve genesys backend's doc to help, and will
gladly apply patches.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LiDE 120, small changes pushed in git

stef-22
On 16/06/2015 11:41, [hidden email] wrote:

> Hello,
>
> I have tested the latest build available from git. Unfortunately I wasn't able to check the version number. which debug logs are you referring to ?
>
> Anyway with the latest build, my LiDe 120 is not supported at all (even with resolution under 600 dpi).
>
> It may well be that I made a mistake at compile or forgot to update a configuration file. Anyone else had a chance to try it ?
>
> Thanks,
>
> Martin
>
> ----- Mail original -----
> De: "Stef" <[hidden email]>
> À: "Sane Development" <[hidden email]>
> Envoyé: Jeudi 11 Juin 2015 21:55:07
> Objet: [sane-devel] LiDE 120, small changes pushed in git
>
>       Hello,
>
>       I have pushed some small changes that should improve support for
> the LiDE 120 for resolutions up to 600 dpi. Please test this build 2507
> of the geneys backend (check this version number in debug logs when
> testing).
>       Working with some logs sent, then throwing back some code to
> someone else to test isn't practical. I don't feel like going on that
> way. So people interested by adding support for this model (or another
> one) should clone SANE's git tree and syseneg project (which provides a
> tool to analyze pcap usb logs), and start hacking it.
>       I'd be happy to improve genesys backend's doc to help, and will
> gladly apply patches.
>
> Regards,
>       Stef
>
     Hello,

     the backend generates traces when these environment variables are set:
export SANE_DEBUG_GENESYS=255
export SANE_DEBUG_GENESYS_LOW=255
export SANE_DEBUG_GENESYS_GL124=255

     then run your frontend from the same command prompt where you typed
these commands, for instance you can run scanimage like this:
scanimage -d genesys --resolution 75 --preview --mode Color 2>rl.log >rl.pnm

rl.pnm will be the scan, while rl.log will contain all debug traces.

Regards,
     Stef


--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LiDE 120, small changes pushed in git

martin.gallezot
Stef,

Ok got it. Thanks.
will try this asap and let you know.

Martin.

----- Mail original -----
De: "Stef" <[hidden email]>
À: "martin gallezot" <[hidden email]>, [hidden email]
Envoyé: Mercredi 17 Juin 2015 20:44:23
Objet: Re: [sane-devel] LiDE 120, small changes pushed in git

On 16/06/2015 11:41, [hidden email] wrote:

> Hello,
>
> I have tested the latest build available from git. Unfortunately I wasn't able to check the version number. which debug logs are you referring to ?
>
> Anyway with the latest build, my LiDe 120 is not supported at all (even with resolution under 600 dpi).
>
> It may well be that I made a mistake at compile or forgot to update a configuration file. Anyone else had a chance to try it ?
>
> Thanks,
>
> Martin
>
> ----- Mail original -----
> De: "Stef" <[hidden email]>
> À: "Sane Development" <[hidden email]>
> Envoyé: Jeudi 11 Juin 2015 21:55:07
> Objet: [sane-devel] LiDE 120, small changes pushed in git
>
>       Hello,
>
>       I have pushed some small changes that should improve support for
> the LiDE 120 for resolutions up to 600 dpi. Please test this build 2507
> of the geneys backend (check this version number in debug logs when
> testing).
>       Working with some logs sent, then throwing back some code to
> someone else to test isn't practical. I don't feel like going on that
> way. So people interested by adding support for this model (or another
> one) should clone SANE's git tree and syseneg project (which provides a
> tool to analyze pcap usb logs), and start hacking it.
>       I'd be happy to improve genesys backend's doc to help, and will
> gladly apply patches.
>
> Regards,
>       Stef
>
     Hello,

     the backend generates traces when these environment variables are set:
export SANE_DEBUG_GENESYS=255
export SANE_DEBUG_GENESYS_LOW=255
export SANE_DEBUG_GENESYS_GL124=255

     then run your frontend from the same command prompt where you typed
these commands, for instance you can run scanimage like this:
scanimage -d genesys --resolution 75 --preview --mode Color 2>rl.log >rl.pnm

rl.pnm will be the scan, while rl.log will contain all debug traces.

Regards,
     Stef


--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Canon LiDE 120 Black Image

martin.gallezot
In reply to this post by stef-22
Hello,

I tested the latest build (SANE Genesys backend version 1.0 build 2507 from sane-backends 1.0.25 git) on my LIDE 120. Scanner is recognized, stepper motor are moving but the scan image is 'all black'.

I have set the debug level of Genesys to 255

Any idea what I am doing wrong ?

Thanks,

Martin


----- Mail original -----
De: "Stef" <[hidden email]>
À: "martin gallezot" <[hidden email]>, [hidden email]
Envoyé: Mercredi 17 Juin 2015 20:44:23
Objet: Re: [sane-devel] LiDE 120, small changes pushed in git

On 16/06/2015 11:41, [hidden email] wrote:

> Hello,
>
> I have tested the latest build available from git. Unfortunately I wasn't able to check the version number. which debug logs are you referring to ?
>
> Anyway with the latest build, my LiDe 120 is not supported at all (even with resolution under 600 dpi).
>
> It may well be that I made a mistake at compile or forgot to update a configuration file. Anyone else had a chance to try it ?
>
> Thanks,
>
> Martin
>
> ----- Mail original -----
> De: "Stef" <[hidden email]>
> À: "Sane Development" <[hidden email]>
> Envoyé: Jeudi 11 Juin 2015 21:55:07
> Objet: [sane-devel] LiDE 120, small changes pushed in git
>
>       Hello,
>
>       I have pushed some small changes that should improve support for
> the LiDE 120 for resolutions up to 600 dpi. Please test this build 2507
> of the geneys backend (check this version number in debug logs when
> testing).
>       Working with some logs sent, then throwing back some code to
> someone else to test isn't practical. I don't feel like going on that
> way. So people interested by adding support for this model (or another
> one) should clone SANE's git tree and syseneg project (which provides a
> tool to analyze pcap usb logs), and start hacking it.
>       I'd be happy to improve genesys backend's doc to help, and will
> gladly apply patches.
>
> Regards,
>       Stef
>
     Hello,

     the backend generates traces when these environment variables are set:
export SANE_DEBUG_GENESYS=255
export SANE_DEBUG_GENESYS_LOW=255
export SANE_DEBUG_GENESYS_GL124=255

     then run your frontend from the same command prompt where you typed
these commands, for instance you can run scanimage like this:
scanimage -d genesys --resolution 75 --preview --mode Color 2>rl.log >rl.pnm

rl.pnm will be the scan, while rl.log will contain all debug traces.

Regards,
     Stef


--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Canon LiDE 120 Black Image

stef-22
On 02/07/2015 17:16, [hidden email] wrote:

> Hello,
>
> I tested the latest build (SANE Genesys backend version 1.0 build 2507 from sane-backends 1.0.25 git) on my LIDE 120. Scanner is recognized, stepper motor are moving but the scan image is 'all black'.
>
> I have set the debug level of Genesys to 255
>
> Any idea what I am doing wrong ?
>
> Thanks,
>
> Martin
>
>
>
     Hello,

     this model needs more work to really work. It is currently unsupported.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Canon LiDE 120 Black Image

Pavel Sayekat
Hi,
Now its working, atleast at 300 dpi, I tried with frontend gscan2pdf with latest backend from sane-git, thanks to Stef.

regards
Pavel

stef-22 wrote
On 02/07/2015 17:16, [hidden email] wrote:
> Hello,
>
> I tested the latest build (SANE Genesys backend version 1.0 build 2507 from sane-backends 1.0.25 git) on my LIDE 120. Scanner is recognized, stepper motor are moving but the scan image is 'all black'.
>
> I have set the debug level of Genesys to 255
>
> Any idea what I am doing wrong ?
>
> Thanks,
>
> Martin
>
>
>
     Hello,

     this model needs more work to really work. It is currently unsupported.

Regards,
     Stef

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Loading...