Quantcast

Getting "Error from scsi_read: End of file reached" from hp6200 again

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Getting "Error from scsi_read: End of file reached" from hp6200 again

Marshall Jose-2
I've been using a 6200-series scanner to scan piano rolls, which involves the repetitious scanning of successive sections of the roll. This process worked well for more than a year, but then gradually I got the "Error from scsi_read: End of file reached" failure an increasing number of times during a roll, to the point now where it's almost unusable.

It's been frustrating to use the sane bug tracker to search for related bugs/fixes, so I brought my appeal here, to see if anyone had any suggestions. I'm currently running Ubuntu 14.04.3, with their 1.0.14-9 distro of sane.

Thanks,
Marshall

--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Getting "Error from scsi_read: End of file reached" from hp6200 again

Marshall Jose-2
After doing a bit more research, I realized that the hp backend is no longer maintained. So I went to "Plan B" and coded a retry loop in my scanning script, which waits for the scanner to "come to its senses" after an end-of-file error, and then resumes the scanning.

Thanks anyway,
Marshall

On Fri, Jan 29, 2016 at 9:57 AM, Marshall Jose <[hidden email]> wrote:
I've been using a 6200-series scanner to scan piano rolls, which involves the repetitious scanning of successive sections of the roll. This process worked well for more than a year, but then gradually I got the "Error from scsi_read: End of file reached" failure an increasing number of times during a roll, to the point now where it's almost unusable.

It's been frustrating to use the sane bug tracker to search for related bugs/fixes, so I brought my appeal here, to see if anyone had any suggestions. I'm currently running Ubuntu 14.04.3, with their 1.0.14-9 distro of sane.

Thanks,
Marshall


--
sane-devel mailing list: [hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
             to [hidden email]
Loading...